website yoast.com is down

Incident Report for Yoast

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 17:36 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 17:19 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jun 29, 2026 - 16:47 CEST

Identified

The issue has been identified and we are implementing a fix.
Posted Jun 29, 2026 - 16:43 CEST

Investigating

We are currently seeing problems with our website yoast.com. We are investigating the problem at the moment.
Posted Jun 29, 2026 - 16:32 CEST
This incident affected: Website (yoast.com).